Video Screencast Help

Not showing green dot

Created: 07 Oct 2009 • Updated: 25 Aug 2010 | 15 comments

I have reinstalled the symantec on a pc in a server environment by going through the deploy wizard from the symantec server.. It installed fine, but the symantec on that pc is not updating, I have 60 other pcs connected to the server and they are getting their definition update fine but this one is showing as 8 November for last update..
It is as well not showing on th symantec enpoint protection manager (SEPM) as being connected as can;t see the pc thier under desktop list.
I can't run live update and need to make the pc download updates through the server itself..
1. What is the issue causing this?
2. What is the simplest way to fix that

My symantec version is "Symantec endpoint protection 2008", the cleint pc is running windows XP

Discussion Filed Under:

Comments 15 CommentsJump to latest comment

Vikram Kumar-SAV to SEP's picture

 make sure this client is communicating with SEPM.
Make sure windows firewall is off.
Replace sylink.xml from the server..
if still does not update download intelligentupdater from symantec websiite and update this client with that.

Vikram Kumar

Symantec Consultant

The most helpful part of entire Symantec connect is the Search button..do use it.

ash2107's picture

I have been able to update the symantec but its still not connecting to the sepm, can see the computer under unknown when i go on spem unmanage client search, but its not showing under the sepm list with the green dot

snekul's picture

I would lean towards a firewall configuration issue at first glance. Check both the server to make sure the connections to SEPM are allowed, and make sure the SEPM server is allowed to recieve connections from the SEP client.

Eric C. Lukens IT Security Policy and Risk Assessment Analyst University of Northern Iowa

ash2107's picture

who do you check that? the server/client is allowing to receive connections?
The firewall is off on the sep client..

Santosh C's picture

If the client is not communicating with SEPM it will ot get updated and will not get any policies.
Pickup sylink.xml from the desired group and replace it on the client that has the issue.

To pickup the correct sylink.xml :

1. In SEPM select the group.
2. Right click on it - Export Communication settings and export it to Desktop
3. Rename the file as Sylink.xml

Now on the Client

1. Start > Run > smc -stop
2.  Navigate to C:\Program Files\Symantec\Symantec Endpoint Protrection\
3. Copy the Sylink.xml that was exported on the server desktop and replace the one in this location.
4. Start > Run > smc -start

Check if the shield in the System tray shows a green dot.
Once the green dot appears the client would get updated after a  little while. 

If the issue still persists, please revert.

Santosh :)

elmar1986's picture

Hello,
My SEPM v 11.0 is installed on a Windows server 2003 machine, with 80 clients, had been running well for last 2 months and since 5 days I see that, though the Manager is updating the Def Files as per schedule, and the Symantec version/date is same as the Manager version/date, the clients, including the SEP server itself, are not getting updated.  The SEP server as well as all clients do not have the green dot on the taskbar icon.
Please advise.  Thank you.

Santosh C's picture

Hi elmar1986,

From what you said it scenario is :
1. SEPM has the latest updates.
2. seems that the Clients are not communicating with SEPM as there is no green dot.

The clients including teh one on the SEPM server may have been configured to get the updates from the SEPM and as they are not communicating with SEPM, they are not getting the updates. So, on the Server SEP client replace Sylink.xml as i mentioned in my previous post - Replace sylink.xml and then right click on  the shield - Update Policy - Wait for a while and see if it gets the latest updates. If yes then Call support to get a tool called Sylink Replacer that can be run from the server to replace sylink.xml on all the clients to reset communication with SEPM. This should resolve the issue. Once the green dot appears clients will start getting updated.

Please revert if this resolves the issue.

Thanks :)

Santosh

AravindKM's picture

Ensure that no firewall is blocking communication between manager and client . 
You can do a telnet to SEPM from client pc in your communication port and see what is the result .If port is open it will open a blank window you can use ctrl+c for coming out from that window(In IIS manager go to the properties of SEPM site it will give you the port no.) For more information regarding port no. refer the below doc
Which communication ports does Symantec Endpoint Protection 11.0 use?

You can use below Article also for troubleshooting
Troubleshooting Client Communication

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

elmar1986's picture

Thank you Santosh C

Since there was no option "Export Communication Settings" when I right clicked the group, I followed the procedure for Pre-MR3 in this article

http://service1.symantec.com/SUPPORT/ent-security.nsf/2326c6a13572aeb788257363002b62aa/13669c4f8319b89e882574e5004e7328?OpenDocument

I carried out the rest of your instructions, but sadly the green dot did not appear.

 

Thanks AravindKM.

Firewalls are OFF but I when I do a telnet (my port is 80), I get the black screen (trying) for a second, then it disappears.

Also using secars?hello,secars returns a "page cannot be displayed" message.

Thanks.
 

Santosh C's picture

Hi elmer1986,

As you are getting 'page cannot be displayed', please let me know the Http Error code and substatus code that appears.
To enable Substatus code :
In IE - Tools - Internet options - Advanced - Under Browsing Disable 'Show Http friendly error message'
Based on that we may be able to proceed further.
Also check the following link as a reference for Http Error codes :
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/64e30660-d2f0-4e90-98cc-1652214a2b93.mspx?mfr=true

Thanks,
Santosh C

elmar1986's picture

Thanks,
The Error is: HTTP Error 404 - File or Directory not found.
Internet Information Services IIS.

I have disabled the "show http friendly error message" and restarted IE, but same error 404, without any substatus code.
(no substatus code appear anywhere).
Thanks again.

AravindKM's picture

Try this
Unable to communicate with reporting component – HTTP 404

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

elmar1986's picture

Thanks everyone, this is solved.  The Port was used by another application on the same IIS machine.
Thanks again.

labyrinth's picture

hi
there is isa server 2006 installed gate server
and when i want to update client version for gate server
gate server lost connection with sepm
when i stop firewall sepm and gate server(sep client) can communicate green dot comes both on gate and sepm

i dont know how i can open port for let them communicate
anybody can help me?

AravindKM's picture

pls create a separate thread for your problem.Since this thread is very old most of the people may ignore it. 

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind